How to change static IP in MXM Dashboard

fileunderFound in Microsoft Xbox
Sort by: Oldest  •  Newest  •  User
If you are attempting to load Xbox Media Center onto your Xbox and you are stuck with MXM because it keeps assigning a static IP address of then you should follow these steps. This works in Windows only for as far as I know.
Make a backup of before proceeding

Step 1 - Prepare a new ltools gamesave ZIP

a) Find your file and right-click it choose "Explore". Now, navigate within the zip file to UDATA/4d530017/62D648EBF155 where you'll find a file called "mxm.xml".
b) Drag this file to your desktop (or anywhere you feel comfortable). Leave the explorer window open. Edit this file using notepad or equivalent. At top of the file you will see:
c) Change this to the network settings you desire. Save and close this file.
d) Drag this file back to the ZIP explorer window overwriting the old mxm.xml file. Close the ZIP explorer window.

Step 2 - Uninstall the UXE exploit

Power your Xbox and you should be in MXM. Goto "ltools" then "UXE menu" then "UXE uninstall". Follow the instructions and wait for the green flashing light before turning, as before with the install.

Step 3 - Remove ltools from the Xbox

Turn on your Xbox and get to the original Dashboard. Navigate to the Mech Assault game save on your Xbox. Press "A" then "Delete".

Step 4 - Copy the altered ltools to the Xbox

Fire up Action Replay on your PC and do the following:
  • delete Run Linux from the memory card (left column)
  • delete Run Linux from the PC save library (middle column)
  • drag the new ZIP file to the PC library
  • copy the Run Linux file to the memory card
Copy the Run Linux gamesave as you have done before to the Xbox.

Step 5 - "Run Linux" again from Mech Assault

Basically, you are repeating the exploit with the new ZIP file complete with the changed IP settings.
This worked for me just now, as I did a test that changed my MXM IP Address to You can change the settings to whatever you like. If you make a mistake on the IP address or subnet, you'll have to do this all over again.
This post was edited by Erik on 2/16/2006 9:40 PM
I had this problem at first, and once you posted this handy solution all I had to do was change the DHCP setting from "FALSE" to "TRUE". Voila! Thanks.

just curious... should my kb/s be higher than 32 average??


Yes. The Xbox is 100 Mbps, and you should be getting very fast transfer speeds if you network components and network card are also 100 Mbps.

Post Reply: